System Requirements and Browser Compatibility

To access Mindflash, listed below are the minimum system requirements:

Internet Connection: 
Cable/DSL or faster 

Browser: 
Firefox: last two major versions (Download)
Chrome: last two major versions  (Download)
Microsoft Edge (Download)
Safari: last two major versions (Download

 

Mobile Devices:

Trainees can take courses on mobile devices operating on Andriod or iOS.  Trainees access their courses in the device's browser.

A 3G connection or better is recommended for taking courses.

Note: Other browser versions may work, but possibly run into some errors or issues. For Mindflash to work optimally, please update to the newest version. 

Still need help? Contact Us Contact Us